Password incorrect
Session verification failed. Please try logging out and back in again, and then try again.
Your session timed out while posting. Please try to re-submit your message.

You may have just installed a board or made changes, either to your version of PHP - such as DreamHost has been trying to encourage - or php.ini has been changed in conjunction with database driven sessions and discover the above error messages, either continuously or apparently at random.

Perhaps you tried deleting cookies and truncating database tables and the problem persists. You will get back in OK, if you change the value of `databaseSession_enable` to zero in your `smf_settings` table but that is more of a workaround than an answer.

This is caused by the additional option of either a comma or hyphen in the `session_id`, when session.hash_bits_per_character = 6 in php.ini (session.hash_bits_per_character = 5 will work, if you wish and are able to change this).

The solution to this is simply to add the comma and hyphen characters to the regex that checks the `session_id`. We are lucky that these are all located in /Sources/Load.php

Find multiple times:
'~^[A-Za-z0-9]{16,32}$~'

Replace with:
'~^[A-Za-z0-9,-]{16,32}$~'

Save the file and upload.

Delete cookies and log in again.

Problem solved!