Yuku serious omission

Author Comment
User avatar

Posts: 28

These omissions usually block the posting, messaging, forum customization on the complete Yuku, and potentially (as a secondary consequence) block links to at least 500 000 sites on the Internet and from reputable companies created some kind of non-existent black list of sites.

Log in anywhere on yuku (RD or OldUI forum), copy next two sentences as it is, from this post, just copy and paste, do not touch its contents. And look what happens when you do only preview, or if you try to post.


Copy and paste quoted sentences:


My friend has a company which produces computer communications equipment. Company name is Brunirsoft.Network equipment is an integral part of their product range.



After attempting to posting or sending above text in the messages you'll always get the same result:


Forbidden

You don't have permission to access /forum/postreply/quick/1/id/ on this server.



*These sentences are specially made as an example and for demonstration.


Greater explanation and user observations about this omissions, explained to the last detail can be found here.

YUKU BUG EXPLAIN

You will see what is the cause and what are the consequences of all potentially possible unless the inability entering this simple sentences.


I have no intention of harming with this criticism no one's reputation, but to clearly point out a problem that exists and that as a longtime member of the Yuku community point out that each user can respond with answers that are a kind of child's play. If someone has no intention of ever hears complaints that are clearly established, I see no reason to some services exist.

Yuku support ignored this question and gave a unrealistic answer, nor recognized the existence of the problem, though familiar with it by a user who has noticed.

User avatar

Admin

Posts: 11073

Unfortunately the link you supplied requires a yuku login, therefore I am unable to see its content. I can guess though...

The issue is the .network domain?

Consider the message you are given if you try to post this. You are receiving a specific message saying your action has been deliberately forbidden. If this were an omission as you say or an oversight, then you would not be receiving a 403.

There is a chance it is a double-bug though. Very low priority because the circumstances are so rare. No disrespect but I would block a .network domain in a flash and give it no further thought. (Equally, I would never choose to use a .network TLD.)

The most likely option is that you have stumbled across either an existing or old internal (local) domain, which was at some time specifically disallowed from use by all other than super-admins. If this is the case and the .network local domain is still in use, then publicly publishing this is unwise, as it may - even though unlikely - be of some use in a future crack attempt. i.e. You may be publicly publishing a security risk.

Rather than all this fuss, would it not be a better idea to push the powers that be (not "customer service") for the ability to post .network domains just like any other and let them sort it out?

It takes less effort than you have gone to in order to find out who the powers that be are, where they are, how they can be contacted and in how many ways.

I don't envy anyone the task of creating the perfect URL regex and I am fairly certain attempting to post a .network URL here will not be picked up by MagicURL but I should still be able to post it using bbCode (just like on ezboard) and it will work. I have no reason to disallow a link to a .network domain, therefore anyone can do it.

This is a live domain without content:

http://andrew.network/

http://andrew.network/

The first is just a paste of the raw URL. The second is a bbCode link. Ha, the first works! :lol

Great marketing! "I own a .network domain and I will not use yuku because I am unable to post my own domain name anywhere on the yuku platform because I am denied!"

User avatar

Posts: 28

Hi Andrew. The forum is now opened without need to be a member.
And you can read it now.

It applies to the entire network, not just on this forum, I mean this BUG.
But you must have registered nick to do a test. (That is rule of the Yuku).

Yes, you're immediately spotted the basis of the problem. That's it.
But, you'll see a potential consequences of the alleged prohibition of the site Nir Soft.

This site is not really on any black list of the Yuku. :)

The new link for this topic with problem explain is:

New Link

It's just a term that runs the blockade, there's more of them, but will not announce until this is resolved.

Many users have begun to complain about on the main YUKU forum, and they do not know the cause of it. It was recently discovered, but Yuku ignored him. (began to attribute it to malware and users infected computers, as individual problem, not like the Yuku problem).

Other blocking terms that were discovered have no point of contact with the site's name or something related to internet :)

User avatar

Admin

Posts: 11073

The logic in that topic is flawed. One domain is a Forumer import and the AOL topic is five and a half years since last edited. The message parser was most likely altered after that point. (That is if it is blocked by the message parser.) Another alternative is that the phrase has been entered in some form of global profanity filter.

The question is: why is "soft.net" being blocked? Let's Google! :D

Nothing obvious turning up. Sure got me curious though! I might have to break out a profile they haven't banned. :P

Aside: Just read the announcement. I see they are giving back what they took away! :lol When yuku was young, supporters could have 10 profiles per account and non-supporters could have 5. They cut that to 3/0 and now are increasing it to 12/0. Of course, do not forget the pump! Roll-up and get your MegaFlame Casio
chips here, so we can scr3w more money from you!

Hey, back on topic. This has sure got my interest. I'm behind the 8-ball right now for time. I want to check this further and see what I can make of it. I'll post back here in the beginning of next week.

User avatar

Posts: 28

We continue the story of infantile Yuku content restrictions in posts, with some kind of global profanity filter, which is forcibly imposed and can not be controlled by the board administrators.

If you want to write something about the Unix or Linux and you accidentally want to mention and write the word etc in this way Image you can safely forget the Yuku forums.

Forbidden

You don't have permission to access /forum/postreply/quick/1/id/ on this server.


Not to mention the thousands of websites that have this name as the name of its subdirectories.

It is in some ways understandable - Yuku use the Apache server platform, but again funny.

As we are at the beginnings of the Internet.

Can you imagine?? :)

/etc/ is forbidden in Yuku posts..


The Consequences:

1 You can not write serious texts about the Unix, Linux and the Apache platform;

2 Blocked hundreds of thousands of sites that have a subdirectory path with the same name;


For example..Try to open a topic (or send someone a message) on Yuku and leave link for the Potsdam Declaration.

This link:

www.ndl.go.jp/constitution/e/etc/c06.html

P.S.

I give a million dollars to the one who set a link in this format on Yuku :rollin

User avatar

Posts: 2263

You can not write serious texts about the Unix, Linux and the Apache platform

Count in the Mac; it also has a hidden /etc directory. Most users never have to touch it, but I happen to have an fstab file in there to prevent unneeded volumes from mounting. (These are generally backups of other computers or rarely needed boot partitions that would serve only to clutter my list of devices.)

I recall one message board that blocked anything that contained s**t. That meant that you couldn't use words like shirt, short, or shrimpboat. This was especially problematic because this was a baseball board, and "short" is commonly used to refer to the shortstop position.

The bottom line is that there shouldn't be any system-wide word restrictions. That should be up to the board owners to decide. I remember that back in the olden days, ezBoard globally prohibited any word containing "applet." That not only made discussion of applets cumbersome, it prevented the posting of "Appleton," a city in Wisconsin. You'd think that technology should have reached a point that it would be unnecessary to prohibit certain words based on security.

User avatar

Posts: 28

Thank you for your post. Yes, I agree that should not be any system-wide word restrictions, especially on the global forum networks. Of course, not to mention that a lot of forum's on the Yuku are bilingual, which increases similar examples of limitations indefinitely.

Unfortunately, there are some "limitations" that are visible failure, but can be attributed (or better say to justified) to this we're talking about.

The answer to the question of some users - why it's blocked this link to the Japanese constitution, their official justification was that this is probably due to the .html at the end of the address.

The question about the "nirsoft" case - the answer was that the site is blacklisted due to spam. When they are asked is it the nonexistent site brunirsoft.net also on the black list, there was no reply.

Especially as all of these examples are not strictly related to the links. :)

User avatar

Posts: 28

Today I'll tell you what the problem with the "ETC" example is.

It is a character encoding and the problem in conversion during the data transfer process, or better to say during data translation.

This format Image is possible on Yuku only if the slashes are entered in posts or messages as HTML entity (decimal): Image

If we use hex entity for slash, conversion will fail.

Yuku standard character encoding is UTF-8.

When decimal is decodable as UTF8, everything will be OK.

So, if you type in the post or message this:

Image

the problem is solved.

This is the simplest explanation to confused users. Why is this happening, it is more a question for Yuku that often these things explained to them inadequately.

One well-known global community network should not itself allow such things.

User avatar

Posts: 28

Well, you did not notice an optical illusion?

It is not enough to access the "Potsdam Declaration" from Yuku. ;)

However, in the case where the etc is part of web address, you must use this format.

Image

Because this is a HTML entity of the original character that is used in hyperlinks.

And link to "Potsdam declaracion" on Yuku must to look like this:

Image


And I was convinced to this day that it was a kind of term that has any chance filtered. So, though we somehow discovered. :)

User avatar

Posts: 28

But this is a serious problem that should be solved and allow users to freely use all the standard characters over keyboard, not to improvise. There are several editors on Yuku, but the thing in a normal way is not working.

Display posts from previous:  Sort by  



Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group